comupter freezes after starting MMS

Talk about running MMS without X either using fbdev or SDL.

Moderator: Moderator

chris48
Posts: 3
Joined: Mon Jun 21, 2010 4:22 pm

comupter freezes after starting MMS

Postby chris48 » Wed Apr 27, 2011 7:44 pm

Hi,

I installed MMS 1:1.1.2 pre7-0 on Ubuntu 10.04 without an XServer running on an old HP OmniBook 4150 (PIII). I want o use it in my kitchen to mainly listen to internet radio. So I wanted to keep the installation as simple as possible.

After I added myself to the video group MMS could access the framebuffer /dev/fb0.

But when I start MMS with

Code: Select all

export SDL_NOMOUSE="1"
mms -o sdl -i keyboard

I just get a dark screen with a mouse pointer in the top left. The computer doesn't react to the keyboard at all so I have to reboot the hard way and cannot see any terminal output.

Are there any log messages saved somewhere?

I also tried to load the framebuffer module with 'modprobe uvesafb' first. But as there is a /dev/fb0 i assume the framebuffer device is working.

Cheers, Chris
Last edited by chris48 on Wed Apr 27, 2011 8:58 pm, edited 1 time in total.

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Re: comupter freezes aftermms starts

Postby acmelabs » Wed Apr 27, 2011 8:20 pm

I don't know uvesafb, and don`t know the resolution it offers
If you use e.g. these switches as your kernel command line

Code: Select all

video=uvesafb:1024x768-32,mtrr:3,ywrap

then I recommend to set the appropriate Resolution in /etc/mms/Config

Code: Select all

# Resolution
h_res = 1024
v_res = 768


The log could be produced like this:

Code: Select all

mms -o sdl -i keyboard > /var/log/mms.log 2>&1


Regards,
Andreas

PS: didn't even know it`s possible to use it w/o an Xserver. I'm using xinit in combination with openbox (very light window manager).It's the perfect team!

This is how I start it (my log goes directly into the xterm window):

/home/acme/.xinitrc

Code: Select all

exec openbox-session &
unclutter &
xterm -font 12x24 -fg green -bg black -geometry 80x25+100+100 mms


/home/acme/.bash_profile

Code: Select all

#!/bin/sh
xinit   -- :0 -dpi 140
logout

chris48
Posts: 3
Joined: Mon Jun 21, 2010 4:22 pm

Re: comupter freezes after starting MMS

Postby chris48 » Wed Apr 27, 2011 9:47 pm

Thanks Andreas for your quick support.

My screen resolution from the boot command line is 800x600 (video=uvesafb:mode_option=800x600-24), same as in /etc/mms/Config.
aqqqq
I saved the output to the log file as you advised. But there are only 5 lines telling me which configuration file and which directories MMS used although I increased the debug level to 3 in the MMS Config file.

If I skip the 'export SDL_NOMOUSE="1"' I get a bunch of additional lines in the log file, ending with the error that the mouse could not initialized.

So I might end up installing an XServer. Do I need a window manager or would it do just with the XServer? Is there anything else I can try?

Cheers, Chris

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Re: comupter freezes after starting MMS

Postby acmelabs » Thu Apr 28, 2011 5:51 am

chris48 wrote:...

So I might end up installing an XServer. Do I need a window manager or would it do just with the XServer? Is there anything else I can try?

No - no windows manager needed. A tiny windows manager like matchbox or openbox would give you the ability to switch between windows and desktops though. After installing the Xserver, you can launch mms like this from the command line:

Code: Select all

xinit -e mms -o sdl -i keyboard

And no - I don't know what you can try else, because I'm not familiar with such kind of drivers.
I'm the NVidia GPU-Acceleration guy ;-)

Regards,
Andreas

PS: A tiny windows manager like matchbox or openbox would give you the ability to switch between windows and desktops though.

chris48
Posts: 3
Joined: Mon Jun 21, 2010 4:22 pm

Re: comupter freezes after starting MMS

Postby chris48 » Thu Apr 28, 2011 7:28 pm

So now I have installed an XServer and MMS is really starting, unfortunately without mouse suppoert (touchpad).

But even worse the menu is quite limited, a search button, an exit one, a configuration one (with no options behind) and a theme one.

How can I enable internetradio support? Do I have to edit the Config file?

@Andreas: Just to be curious, as I am still looking for a ligtweight windowmanger for my old computers. Would Openbox be your first choice? Better / faster than for example Fluxbox?

Regards, Chris

User avatar
naicheben
Overlord
Posts: 1332
Joined: Tue Apr 04, 2006 12:50 pm
Location: Germany/Leck
Contact:

Re: comupter freezes after starting MMS

Postby naicheben » Thu Apr 28, 2011 9:46 pm

You will have to install mms-audio-alsaplayer or mms-audio-xine to enable Audio.

Internetradio is broken. You can still listen to your own internet radio stations, but not via shoutcast. To configure your internet radio stations edit your ~/.mms/RadioStations
"Stationname, http://streamURL"
mit Hellseherschein ;.)

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Re: comupter freezes after starting MMS

Postby acmelabs » Fri Apr 29, 2011 8:20 am

chris48 wrote:So now I have installed an XServer and MMS is really starting, unfortunately without mouse suppoert (touchpad).

But even worse the menu is quite limited, a search button, an exit one, a configuration one (with no options behind) and a theme one.

How can I enable internetradio support? Do I have to edit the Config file?

@Andreas: Just to be curious, as I am still looking for a ligtweight windowmanger for my old computers. Would Openbox be your first choice? Better / faster than for example Fluxbox?

Regards, Chris

Well, as you can imagine mouse support is not the matter of mms, but your drivers actually. My mouse is doin' fine here ;-)
You've installed the very basic core of mms. That's OK but useless do a

Code: Select all

apt-cache search mms-

to see see what else is available.

Web-Radio, as mentioned by Ingmar is broken, but will get a fix by the weekend, hopefully :)

I don't know the difference between flux- and openbox. I'm just happy with 'no features' at all, because I don't need them. I can remove the window borders of mms in pseudo-fullscreen mode, and can swtich between my open windows (most of them chrome and xterm), that's all I need.

/etc/mms/Config

Code: Select all

# If you selected sdl as output device this setting will determine if
# it should run in fullscreen or not.
#
fullscreen = false


.config/openbox/rc.xml

Code: Select all

<openbox_config>
 <applications>
  .
  .
  <application name="mms">
        <decor>no</decor>
        <fullscreen>yes</fullscreen>
  </application>
  </applications>
</openbox_config>



Regards,
Andreas


Return to “framebuffer”

Who is online

Users browsing this forum: No registered users and 0 guests