Stable down 1.0.8.1 (work in progress ;)

everything about the previous stable version

Moderator: Moderator

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Postby acmelabs » Fri Dec 15, 2006 10:58 am

Uatschitchun wrote:Thx

Anders, could you patch-in lirc-debug prints? Thus would help fixing the lirc-loosing, I hope!

Lg
Roman


See also here
http://mms.kicks-ass.org/forum/viewtopi ... =2309#2309

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Sun Dec 17, 2006 12:53 pm

I'll keep collecting ;)

If audio-stop-on-clear is false, the current playlist is emptied and new songs are added, MMS looses id3-tag infos of currently played song (cause it isn't in the list anymore)

Lg
Roman

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Sun Dec 17, 2006 8:36 pm

Do you have a screenshot where I can see the epg options graphics bug? Seems to work ok here.

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Postby acmelabs » Sun Dec 17, 2006 9:04 pm

arj wrote:Do you have a screenshot where I can see the epg options graphics bug? Seems to work ok here.

If this is addressed to me, then there is no bug for me. This is more a change-request, to make epg works with text and logos at the same time.
I'll never be able to collect all needed icons, because the channel list, hence the epg.data is changing too fast, and I can't provide icons for all of this channels.

Regards,

Andreas

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Sun Dec 17, 2006 10:21 pm

No it was meant for Roman :)

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Mon Dec 18, 2006 10:18 am

Here you are:
Image

Lg
Roman

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Mon Dec 18, 2006 4:38 pm

Update

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Mon Dec 18, 2006 8:32 pm

Fixed 50 + 52

Thanks

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Re: Stable down 1.0.8.1 (work in progress ;)

Postby arj » Mon Dec 18, 2006 9:42 pm

Uatschitchun wrote:05 [*] Noticed after clean install, that the volume was "muted" or even "0" ... without showing the mute symbol ... new users might be confused! Wouldn't it be possible to set an initial volume? (Maybe it was only me having trouble with it :)


I Could reproduce after installing the deb on ubuntu. Can't seem to reproduce it now though. I deleted the ~/.alsaplayer folder and cleared the /etc/mms/options file without luck :(

We really need this fixed before 1.0.8.1.

Uatschitchun wrote:06 [*] Even between usages the volume is not saved correctly (alsaplayer) !? (Quest.: Where is it saved?)


This one seemed to work ok?

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Re: Stable down 1.0.8.1 (work in progress ;)

Postby arj » Mon Dec 18, 2006 10:05 pm

Uatschitchun wrote:51 [*]Translations (will be done shortly before release):
* "Playliste laden" should be "Playliste - laden"
* "Play track now"
* "Playing track" in audio-screensaver
(Quest.: Are there other german translation issues or wishes?)


Could you update the german translations and send it to me? There won't be any more translation changes. I've sent the word out to the translation horde :-)

Thanks

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Tue Dec 19, 2006 11:51 am

arj wrote:Fixed 50 + 52

50 is ok now ...

52 is still present!

Way to reproduce:
Add a song to the list, play it, wait for screensaver (displays cover+tags), go to playlist, clear playlist, songs still playing (audio_stop_on_clear=false), add complete different song to the list, wait again for the _screensaver_ (no cover, no tags)

Lg
Roman

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Re: Stable down 1.0.8.1 (work in progress ;)

Postby Uatschitchun » Tue Dec 19, 2006 3:04 pm

arj wrote:Could you update the german translations

in progress ...

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Wed Dec 20, 2006 10:34 am

Hi there ... I cleanded up the list a bit ... see changelog in the first post.
I moved some "bugs" to 1.0.9. Hope you all go with me?

From the left open ones I would suggest:

Have to be fixed for 1.0.8.1
05 [*] Noticed after clean install, that the volume was "muted" or even "0" ... without showing the mute symbol ...

06 [*] Even between usages the volume is not saved correctly (alsaplayer) !?

11 [*] Consistent handling of cover.jpg

29 [*] Corruptions in zoomed picture-fullscreen while playing audio and transparent busy-indicator is not transparent

46 [*] configure complains: test: 855: ==: unexpected operator

52 [*]If audio-stop-on-clear is false, the current playlist is emptied and new songs are added, MMS looses id3-tag infos of currently played song

For #11 MMS should respect an existing cover.jpg correctly in 'Movies'!

Nice to have in 1.0.8.1 but OK in 1.0.9
48 [*] make PAGE_DOWN and PAGE_UP button work for EPG, too

24 [*] Should we add switches for 'mms-audio-library' and 'mms-picture-library' to configure and Makefile getting them build and installed at compile time?


Still has to be tested
16 [*] Loosing Lirc over time


These are my votes and wishes for a nice christmas 'Teerklumpen' containing 1.0.8.1 :twisted:

What do you say?

Lg
Roman

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Wed Dec 20, 2006 8:19 pm

Uatschitchun wrote:11 [*] Consistent handling of cover.jpg

For #11 MMS should respect an existing cover.jpg correctly in 'Movies'!


List looks good. But I don't really understand this one. Lets say you have a folder with a movie like this:

Terminator 2/
Terminator 2/CD1
Terminator 2/CD2

If you place a jpg file in Terminator 2/ it will be displayed as the image for the movie. It will also overwrite the imdb cover that imdb has on the movie.

Could you give me an example of what it is exactly that doesn't work?

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Wed Dec 20, 2006 8:28 pm

Uatschitchun wrote:46 [*] configure complains: test: 855: ==: unexpected operator


Fixed in patch-53.


Return to “1.0.8”

Who is online

Users browsing this forum: No registered users and 2 guests