Stable down 1.0.8.1 (work in progress ;)

everything about the previous stable version

Moderator: Moderator

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Stable down 1.0.8.1 (work in progress ;)

Postby Uatschitchun » Tue Nov 21, 2006 9:58 am

Ok, I'll try to keep up testing 1.0.8.1 ...

---------------------- Changelog ----------------------------------------------

22.12.06
* added 55, 56, 57, 58
* fixed 55, 56, 57, 58, 45
* changed 11
* moved 11 to 08@1.0.9
* obsoleted 24

Later changelogs are moved to the bottom for getting a better overview

---------------------- Introduction ----------------------------------------------

Cause that things not getting mixed up nor lost, I'll post a summary of what seems to be a BUG still or at least an "incorrectness" ;)

This thread even tries to handle features ... not as newly introduced ones but for consistency in handling and usage

Even if discussion comes up, I'll try to keep the list up to date

So far ... everyone is invited to give feedback to 1.0.8.1 cause it's the stable version coming up!

----------------------- Opem ----------------------------------------------------

These are my finds:

05 [*] Noticed after clean install, that the volume was "muted" or even "0" ... without showing the mute symbol ... new users might be confused! Wouldn't it be possible to set an initial volume? (Maybe it was only me having trouble with it :)

10 [*] A little "weirdness" (for me) regarding "Movies" in when you see folder, a camera-symbol or a cover

16 [*] Loosing Lirc over time -> http://mms.kicks-ass.org/forum/viewtopic.php?p=1624#1624

25 [unproofed] Coming back from Zoom in picture-fullscreen audio-track-display is gone (preview enabled)

29 [*] Corruptions in zoomed picture-fullscreen while playing audio and transparent busy-indicator is not transparent

36 [*] Slow internet hangs mms when listening to radio station - is this one still alive? -> see bug #30 http://mms.kicks-ass.org/flyspray/?do=details&id=30

40 [*] Segfault when using same output with framebuffer? -> http://mms.kicks-ass.org/forum/viewtopic.php?t=451&start=0&postdays=0&postorder=asc&highlight=

48 [*] make PAGE_DOWN and PAGE_UP button work for EPG, too

53 [*]problem with screen refresh with exit mplayer after a movie, show the background in black. The menu items, busy indicator, mms logo show ok when this are redraw

54 [*]play any file of audio, the time jump few seconds. for example:
1:02, 1:03, 1:04, 1:06, 1:07. maybe reduce the idle time of updater ?



-------------------------- Fixed --------------------------------------------

01 [fixed] One is not able to load a Playlist from secondary-menu without having at least 1 song in the playlist! Starting with an empty list, wanting to load one, one has to add at least one song to be able to load a list ... even though there is no defineable key for "playlist,load_playlist" the only way is to make use of secondary-menu! (patch-7)

03 [fixed] When in album-view, wouldn't it be consequent to even add "Play this song now" to secondary-menu ... when having "audio_mode_playnow = true"? (patch-15)

04 [fixed] When in screensaver-mode, shouldn't the busy-indicator be visible if mms is busy and invisible if mms is not busy? When screensaver kicks in and mms is busy, there is no chance to get out of the screensaver unless mms is idle again ... the user might want to know about this and why mms is not reacting (patch-37)

06 [fixed] Even between usages the volume is not saved correctly (alsaplayer) !? (Quest.: Where is it saved?) (patch-55)

07 [fixed] Secondary-menu in pictures gives search when selecting "recurse all from this level" (patch-6)

09 [fixed] edit the version numbering in 1.0.8.1 and 1.0.9 (patch-5)

12 [fixed] Folder-view jumps to first instead of next. If there are (lets say) 11 folders and I've got 5 folders in a row then using "down" in the row 6-10 jumps to the first folder, not to the row with folder 11. This always happens if there is a not-complete row (5). Only when having the cursor on folder 6 using "down" it goes down. (patch-8 & patch-9)

13 [fixed] Should we keep Patch-9 behaviour or should using "down" in the last row should realy go down? (patch-28, patch-39)

14 [fixed] Page_up / Page_down in fancy-mode? (patch-8 & patch-9)

15 [split] Random Modes -> split up into 31-33

17 [fixed] Add alsaplayer Audio-Device hint in config (?):

Code: Select all

 # Audio device
 #
 # standard audio device is /dev/dsp
+# use 'default' when using MMS with alsaplayer


18 [not reproduceable] Bug in picture preview http://mms.kicks-ass.org/forum/viewtopic.php?t=387&start=0&postdays=0&postorder=asc&highlight=

19 [fixed] Consequent fancy arrangement: Even have two-lined names in pictures, too. Resulting in same amount of displayed items in Pictures, Movies, Audio and Games (patch-11)

20 [fixed] Speed up Movie and Games for large folders (patch-10)

21 [fixed] downloaded imdb-covers are broken.
http://mms.kicks-ass.org/forum/viewtopic.php?p=1970#1970 (patch-12 + patch-16)

23 [fixed] Movie: enter or play a "movie-empty" folder not display "Folder empty" (patch-17 + patch-19 + patch-21)

24 [obsolete] Should we add switches for 'mms-audio-library' and 'mms-picture-library' to configure and Makefile getting them build and installed at compile time?

26 [fixed] Make secondary menu works fine in options fullscreen (patch-18)

27 [fixed] Config section 'temp_image_loc' does not represents all cases it is needed for (radio-list-download)

Code: Select all

# Temporary scaled image location
-# Directory where scaled images are placed.
+# Directory where scaled images and other temporary files (radio-list-download) are placed.
(patch-20)

28 [fixed] If temp_image_loc is set to a non-existent folder (ex.:/tmp/mms), the folder mms is not created -> thus radio-list-download is not working (patch-20)

30 [fixed] search-line in 16:9 mode (720x405) uses space on the screen ... MMS has to calculate the amount of items displayed correctly in this case (patch-23)

31 [fixed] 'Intelligent Random' should be fixed (pls test!) (patch-27). It still seems that it plays songs in the list more than once (although no repeat)

32 [fixed] Winamp-Randmom changed in patch-24

33 [fixed] Real- and Winamp Random only play one track since patch-24

34 [fixed] Reget movie-information faulty -> see bug #36.
http://mms.kicks-ass.org/flyspray/?do=details&id=36 (patch-30)

41 [fixed] No-Disk problem when playing DVD's -> see http://mms.kicks-ass.org/forum/viewtopic.php?t=449&start=15&postdays=0&postorder=asc&highlight= (patch-29 + pactch-36)

42 [fixed] Track-number display in screensaver (patch-37)

43 [fixed] "Play track now" in album-view works from the "extra menu", but not with the configured playnow key ("audio_add,play_now") (patch-32)

44 [fixed] Add correct and understandable description of random modes to the Wiki

45 [fixed] Patch-30 (reget movie information) gone too far, it disabled imdb search for folders with multiple folders in it.: a directory should be recognized as a single "movie" or in this case series (patch-30, patch-38, patch-41)

46 [fixed] configure complains: test: 855: ==: unexpected operator (on another system this is where it checks for alsaplayer) (patch-53)

47 [fixed] New icon for EPG or TV needed cause they are the same (patch-40)

50 [fixed] There seems to be a little graphics bug EPG -> options (patch-42)

51 [fixed]Translations (will be done shortly before release):
* "Playliste laden" should be "Playliste - laden"
* "Play track now"
* "Playing track" in audio-screensaver
(Quest.: Are there other german translation issues or wishes?)(patch-47-50)

52 [fixed]If audio-stop-on-clear is false, the current playlist is emptied and new songs are added, MMS looses id3-tag infos of currently played song (cause it isn't in the list anymore) (patch-43 + patch-54)

55 [fixed] /var/cache/mms should be created within Makefile and set correct permissions (patch-58)

56 [fixed] Fix the config's top: Wrong name & Wrong link to documentation (patch-57)

57 [fixed]After adding an album to the playlist with "Play now" and switching on "Winamp Random" after it has started playing I get:
mms: shuffle_list.cpp:29: const Simplefile ShuffleList::next_track(): Zusicherung »shuffle_list.size() > 0« nicht erfüllt. (patch-59)

58 [fixed]Fix library builders:
Add method to compile and install all library builders:
- make library-builders
- make library-builders-install
- Save imms.log in the correct dir
- Create the libraries in the correct places (patch-58)

----------------------------- 1.0.9 -------------------------------------------

01 [1.0.9] Rename "audio_general,playlist_mode" to "audio_general,playlist_load" or even a better hitting name for what it does?

02 [1.0.9] Recursive update for movie-information -> see:
http://mms.kicks-ass.org/flyspray/?do=details&id=36 and
http://mms.kicks-ass.org/forum/viewtopic.php?t=271

03 [1.0.9] Resort option for album-view: Album-view shows tracks on the right side and artist left above the cover. For compilations (or large mixed folders) switching these could help browsing for artists

04 [1.0.9] Search is always starting at the beginning ... searching for "slave" would never bring up "audioslave" ;( Couldn't the search act more in a 'grep'-way? So when doing a search in album-view it _only_ searches for artists, not for titles! This is not nice on Compilations and sensless for Single-Artists-Albums -> Possible to backport the "grep"-search from 1.1.0?

05 [1.0.9] Support movies with resolution larger than 800x600 in DXR3 output - is it still present? -> see bug #27 http://mms.kicks-ass.org/flyspray/?do=details&id=27
What about integration of mplayer.sh script from VDR ... but this is more like a feature!

06 [1.0.9] 3 types of movie-covers: imdb cover, no imdb cover found and not yet looked up

07 [1.0.9] default to --enable--picture-epg, but simply show text, if no icon can be found in /etc/mms/epg_icons

08 [1.0.9] Consistent handling of covers in all modules. By now we have covers in Music, Movies (inconsistent), Games. Pictures is missing!


-------------------------- Changelog ----------------------------------------

21.12.06
* fixed 06, 52, 46

20.12.06
* fixed 51, 31, 32, 33
* renumbering 1.0.9
* moved to 1.0.9: 11b (6), 49 (7)
* changed 11a to 11

19.12.06
* fixed 50,
* changed 52

18.12.06
* added 53, 54

17.12.06
* added 52
* fixed 44

15.12.06
* fixed 4, 42, 47
* sum up different translation issues (8,22,42) into 51
* changed 45, 13, 29

14.12.06
* added 46, 47, 48, 49, 50

13.12.06
* added 44, 45
* fixed 34, 43, 41
* changed 35
* split 11 into 11a+b
* moved to 1.0.9 2, 35, 37, 38, 39

12.12.06
* split up 15 into 31-33
* changed 8+22
* added 34, 35, 36, 37, 38, 39, 40, 41, 42, 43
* fixed 13

07.12.06
* fixed 30
* fixed 21
* changed and partly fixed 15

04.12.06
* fixed 23

01.12.06
* added 30
* fixed 27 + 28

27.11.06
* added 26 + 27 + 28 + 29
* fixed 26
* changed 21 + 23 + 25
* moved 18

26.11.06
* changed 21 + 15
* fixed 17 + 3
* added 22 + 23 + 24 + 25

25.11.06
* added 21

24.11.06
* [added] 19 + 20
* [fixed] 19 + 20
* Added patch versions to fixed items
* Moved 2 to 1.0.9

23.11.06
* changelog added
* Added numbering
* [fixed] 12 + 14
* [added] 13 + 17 + 18


Lg Roman
Last edited by Uatschitchun on Fri Dec 22, 2006 12:26 pm, edited 57 times in total.

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Cover handling in Movies and Pictures

Postby Uatschitchun » Tue Nov 21, 2006 10:12 am

So ... coming from this post in the thread "Change Dir in my Video Directorys very slow"
http://mms.kicks-ass.org/forum/viewtopic.php?p=1887#1887
I want to go further on here to keep things On-Topic ;)

I'll post the screenshot again for easier understanding
Image


arj wrote:
Uatschitchun wrote:There is the same jpg in "Kino" and "Movies" ... So why is one as cover and the other not?


I think it is getting confused about your directory structure. Something like this would explain it:

Kino/
Kino/movie1/
Kino/movie2/
...

Movies_unbearbeit/movie_something.avi
Movies_unbearbeit/movie2.mpg

Is that right? If not could you post the directory structure to? You can always send in a mail or scramble the filenames if they are sensitive :-)

No, my structure is as follows:

Kino/
Kino/movie1/movie1.avi
Kino/movie1/movie2.avi
Kino/movie2/
...
Kino/movie.avi
Kino/cover.jpg

The structure in "Movies_unbearbeitet" is the same!

arj wrote:
Uatschitchun wrote:Second, why and when is there a "camera" symbol instead of a folder? (ex. "Bilder")


The camera represents a movie and the folder represents a number of movies. Like the Musik vids folder you have.


Not quite right ... Sorry ;)
Ok, there are movies in "Bilder" but not directly underneath the folder "Bilder" ... like this:

Bilder
Bilder/Folder1
Bilder/Folder1/Folder1
Bilder/Folder1/Folder1/movie.mpg
Bilder/Folder2
...

First off, I would expect the camera-symbol only for movies themselves, like we have the notes-symbol for audio, and a folder-symbol for folders (replaceable by covers!) <--- This would be my favorite cause it's corresponding to like it is in "Music" ;)

If we use the camera-symbol for folders _and_ movies, the regarding folder should have at least one movie directly underneath, so I can use "Play all in this folder" on it. With this the camera represents an "I'm playable" situation for folders _and_ movies and if I see a folder-symbol I know I have to enter deeper within

arj wrote:
Uatschitchun wrote:Third, could it be possible to have covers in "Pictures", too?


Cover for folders? Like taking a random, or having a screen where you can select the photo for the folder?

The last one would be very nice ... a second-action command like "Use this picture as cover" and a "script" that copies the corresponding thumbnail over to "cover.jpg" (Btw. this would be a _new_ feature and therefore has to put over to 1.0.9 or later ;)

No, just keep it simple and go the stringent way ... use "cover.jpg" if it is there or, if it isn't, use the first picture as cover. Maybe this "feature" should be configureable (No_covers, Only_cover.jpg, Cover.jpg_or_first_picture) ... not every folder has pictures inside, one wants others to see as cover :oops:

Lg
Roman

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Re: Stable down 1.0.8.1 (work in progress ;)

Postby arj » Tue Nov 21, 2006 11:06 pm

Excellent idea. I'll start with the easy ones :-)

Uatschitchun wrote:[*] One is not able to load a Playlist from secondary-menu without having at least 1 song in the playlist! Starting with an empty list, wanting to load one, one has to add at least one song to be able to load a list ... even though there is no defineable key for "playlist,load_playlist" the only way is to make use of secondary-menu!


It is called playlist_mode. Thinking about it, it's clearly not the best name:

# mode = toggle playlist, playlist_mode = select playlist
audio_general,mode,HOME
audio_general,playlist_mode,INS

I had to cover it with a comment. :oops:

Anyway I added the "load playlist" from playlist only to audio add also. Good catch!

Uatschitchun wrote:[*] Secondary-menu in pictures gives search when selecting "recurse all from this level"


Patch-6.

Uatschitchun wrote:[*] Folder-view jumps to first instead of next. If there are (lets say) 11 folders and I've got 5 folders in a row then using "down" in the row 6-10 jumps to the first folder, not to the row with folder 11. This always happens if there is a not-complete row (5). Only when having the cursor on folder 6 using "down" it goes down.


Yeah it's meant to do that but I can see your point. Fixed in patch-8.

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Re: Stable down 1.0.8.1 (work in progress ;)

Postby Uatschitchun » Wed Nov 22, 2006 10:02 am

arj wrote:Excellent idea. I'll start with the easy ones :-)

Thx!
Start where ever you want ;)

arj wrote:
Uatschitchun wrote:[*] One is not able to load a Playlist from secondary-menu without having at least 1 song in the playlist! Starting with an empty list, wanting to load one, one has to add at least one song to be able to load a list ... even though there is no defineable key for "playlist,load_playlist" the only way is to make use of secondary-menu!


It is called playlist_mode. Thinking about it, it's clearly not the best name:

# mode = toggle playlist, playlist_mode = select playlist
audio_general,mode,HOME
audio_general,playlist_mode,INS

I had to cover it with a comment. :oops:

Anyway I added the "load playlist" from playlist only to audio add also. Good catch!

Fine!

Shouldn't we think about renaming "playlist_mode" to "playlist_load" ?

arj wrote:
Uatschitchun wrote:[*] Secondary-menu in pictures gives search when selecting "recurse all from this level"


Patch-6.

Jepp, works!

arj wrote:
Uatschitchun wrote:[*] Folder-view jumps to first instead of next. If there are (lets say) 11 folders and I've got 5 folders in a row then using "down" in the row 6-10 jumps to the first folder, not to the row with folder 11. This always happens if there is a not-complete row (5). Only when having the cursor on folder 6 using "down" it goes down.


Yeah it's meant to do that but I can see your point. Fixed in patch-8.


That was not the point but is nice, too :twisted:

Let me first coment on patch-8:
I think there has to be a rework of "Page-up and Page-down"!
Using MMS in different resolutions the amount of displayed items changes. I use MMS on my laptop (1680x1050) and on TV (800x600). Thus giving the following:
1680x1050
Audio => 11*5
Movie => 11*5
Pictures => 10*6
Games => not tested

800x600
Audio => 5*2
Movie => 5*2
Pictures => 5*3
Games => not tested

Now we have config option

Code: Select all

# page_up and page_down jump range
jump = 10

How should one configure this correctly, when there are different amounts of items to be "jumped over"? I think this option is kind a useful with fancy-mode disabled, cause one has a straight amont of lines there ...
For fancy-mode I would deactivate this option and realy jump one page ... we could get the amount of "jumped over" items from the code, couldn't we?
So with this (together with patch-8) we do jump one page in fancy-mode, no matter what resolution one is using or how many items are displayed ... and ... patch-8 stops at the last item in the list.



On to what I meant with "Folder-view jumps to first instead of next":
I've got this situation:
Image
Pressing "down" (not page_down) gives:
Image
Pressing "down (not page_down) again gives:
Image

So with key "down" MMS only moves on to the last (incomplete) line, if the corsor is above an item ... if the cursor is above no_item it jumps to the first. I would expect MMS to jump over to the last item in the "incomplete" row ... even because of sometimes the "incomplete" row is not yet showing up when the last "complete" line is on the bottom of the screen, I'll have to use "down", "up" plus several "right" to get where I expect one single "down" has put me to ...

Pick what I mean? :roll:

Lg
Roman

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Rescanning folders on "back"

Postby Uatschitchun » Wed Nov 22, 2006 10:43 am

Is it right that MMS scans the folders for corresponding file-types when entering it (ex. movies or games)?

Is it also right that it does the same thing again when leaving a folder with "back"?

Example:
Enter games -> MMS scans all configured folders for file-types
Enter a subfolder -> MMS scans again
Going Back -> MMS scans again what has been scanned already in the first step
???

If I'm right, isn't one scan (first scan) enough until one hits "reload" in options? And what about caching?
Wouldn't that speed up things a lot?

Lg
Roman

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Random Modes

Postby Uatschitchun » Wed Nov 22, 2006 10:48 am

Some questions regarding random modes in audio ...

Has someone "intelligent-random" working as it should?
Here it sometimes always starts with the same song and not getting further on (like repeat). Manualy starting another song, the next one is the first-played again?
What about the numbering? I notice no change if a song is played completly (should change +1) or skipped (should change -1), shouldn't it?

Real-Random plays songs twice after a time (repeat is off)?
I would expect it to play all songs in the playlist once, but all of them in random order ...

Lg
Roman

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Re: Stable down 1.0.8.1 (work in progress ;)

Postby arj » Wed Nov 22, 2006 7:14 pm

Uatschitchun wrote:
arj wrote:
Uatschitchun wrote:[*] One is not able to load a Playlist from secondary-menu without having at least 1 song in the playlist! Starting with an empty list, wanting to load one, one has to add at least one song to be able to load a list ... even though there is no defineable key for "playlist,load_playlist" the only way is to make use of secondary-menu!


It is called playlist_mode. Thinking about it, it's clearly not the best name:

# mode = toggle playlist, playlist_mode = select playlist
audio_general,mode,HOME
audio_general,playlist_mode,INS

I had to cover it with a comment. :oops:

Anyway I added the "load playlist" from playlist only to audio add also. Good catch!

Fine!

Shouldn't we think about renaming "playlist_mode" to "playlist_load" ?


I would like 1.0.8.1 to only be bugfixes so that one doesn't have to change anything -- including the input files. It's actually a playlist_load_toggle since you can change back again from playlist load :)

Uatschitchun wrote:
arj wrote:
Uatschitchun wrote:[*] Folder-view jumps to first instead of next. If there are (lets say) 11 folders and I've got 5 folders in a row then using "down" in the row 6-10 jumps to the first folder, not to the row with folder 11. This always happens if there is a not-complete row (5). Only when having the cursor on folder 6 using "down" it goes down.


Yeah it's meant to do that but I can see your point. Fixed in patch-8.


That was not the point but is nice, too :twisted:

Let me first coment on patch-8:
I think there has to be a rework of "Page-up and Page-down"!
Using MMS in different resolutions the amount of displayed items changes. I use MMS on my laptop (1680x1050) and on TV (800x600). Thus giving the following:
1680x1050
Audio => 11*5
Movie => 11*5
Pictures => 10*6
Games => not tested

800x600
Audio => 5*2
Movie => 5*2
Pictures => 5*3
Games => not tested

Now we have config option

Code: Select all

# page_up and page_down jump range
jump = 10

How should one configure this correctly, when there are different amounts of items to be "jumped over"? I think this option is kind a useful with fancy-mode disabled, cause one has a straight amont of lines there ...
For fancy-mode I would deactivate this option and realy jump one page ... we could get the amount of "jumped over" items from the code, couldn't we?
So with this (together with patch-8) we do jump one page in fancy-mode, no matter what resolution one is using or how many items are displayed ... and ... patch-8 stops at the last item in the list.



On to what I meant with "Folder-view jumps to first instead of next":
I've got this situation:
Image
Pressing "down" (not page_down) gives:
Image
Pressing "down (not page_down) again gives:
Image

So with key "down" MMS only moves on to the last (incomplete) line, if the corsor is above an item ... if the cursor is above no_item it jumps to the first. I would expect MMS to jump over to the last item in the "incomplete" row ... even because of sometimes the "incomplete" row is not yet showing up when the last "complete" line is on the bottom of the screen, I'll have to use "down", "up" plus several "right" to get where I expect one single "down" has put me to ...


Wow I'm impressed, where do you get it from? Truly excellent suggestions! Implemented in patch-9 :D

Keep it coming!

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Re: Rescanning folders on "back"

Postby arj » Wed Nov 22, 2006 7:17 pm

Uatschitchun wrote:Is it right that MMS scans the folders for corresponding file-types when entering it (ex. movies or games)?


Yes

Uatschitchun wrote:Is it also right that it does the same thing again when leaving a folder with "back"?

Example:
Enter games -> MMS scans all configured folders for file-types
Enter a subfolder -> MMS scans again
Going Back -> MMS scans again what has been scanned already in the first step
???

If I'm right, isn't one scan (first scan) enough until one hits "reload" in options? And what about caching?
Wouldn't that speed up things a lot?


Yes. Interesting idea. I'll see what kind of numbers I get here.

Currently Reload corresponds to the example you mentioned.

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Re: Rescanning folders on "back"

Postby Uatschitchun » Wed Nov 22, 2006 8:39 pm

arj wrote:Yes. Interesting idea. I'll see what kind of numbers I get here.
I'm curious, too!

Lg
Roman

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Wed Nov 22, 2006 9:20 pm

It took 14 ms to exit from one subdir to the main audio list. So it doesn't seem worthwhile to look more into it.

I guess the operating system caches a lot of the accesses. Furthermore the cache that was implemented for entering dirs should also help quite a big since all the folders + files has been stat'ed.

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Re: Rescanning folders on "back"

Postby acmelabs » Thu Nov 23, 2006 2:20 am

Hi
@Roman
Could you add this to your list, if anybody is able to reproduce it?
http://mms.kicks-ass.org/forum/viewtopic.php?p=1935#1935

Thanks,

Andreas

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Thu Nov 23, 2006 8:19 am

Hi acmelabs ... pls see you post!

@all
As I did the tests for acmelabs, I noticed why we have different amount of items displayed in Audio/Movie and Pictures :lol:

There is no name-wrapping (only a single lined name, not two lines) in Pictures like there is in Audio and Movie ... could this give the extra place in vertical to display more items?
So the solution for a consistent view arrangement _and_ the "Page_up/down" problem (jump range in config) could be to have name-wrapping into two lines in Pictures, too 8)

Btw. this would make navigating a lot easier! All my picture folders are named "yyyy-mm-dd - Name_or_Headline_or_Event" ... so by now MMS displays: "yyyy-mm-dd - max_4_letters" ...

Lg
Roman

P.S. BrainPills working again :twisted:

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Thu Nov 23, 2006 9:21 am

arj wrote:It took 14 ms to exit from one subdir to the main audio list. So it doesn't seem worthwhile to look more into it.


Ok, I do agree ... done some time tests ...

But if I use a drive (300GB) with Games containing not one game-filetype it uses up to 2.35 min (1.21) to enter Games for the first time ... 2nd time is 37sec, 3rd is 27sec and 4th is 37sec ... ;(
Using that same drive with Audio (even not one single mp3 on it) MMS needs a max. of 2-5sec to enter Audio or change folders !?

Using another drive (300GB) with only 10 files corresponding to game-filetypes (but are not games - like a .bin image) MMS needs 25sec to enter Games

Playing around, Audio and Pictures _are_ a lot faster than Games and Movies? Is it because of the more filetypes for Movie and Games MMS has to check for?
Test: All my shared media for all Modules in MMS (/media)
Entering test:
Audio: 1-2s
Picture: 1-2s
Movie: 1.13min (2.12min)
Games: 1.14min

All tests were done per wireless!

I feel it's not acceptable to wait over 1 minute until MMS enters a module :roll:

Lg
Roman

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Postby acmelabs » Thu Nov 23, 2006 10:07 am

Hi,

well - I do have a few audio folders here, where it takes up to 45 secs to enter a folder the first time over NFS. This is what I call 'usable', but definitely not fast. Whereas all cached operations are fast as hell. Since I'm using suspend to RAM this problem hits me only the first time :-)

I've often been told to rearange the directory-structure, but:
This audio-collection is maintained by a couple of people, and they won't be very pleased if I change something.

I know in comparison to former times, the audio navigation is lightning fast, and now I've got the feeling, the problems from the past hit us again, only in different places. The good thing is, we have a busy indicator in the meantime ;-)

Regards,

Andreas

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Thu Nov 23, 2006 3:43 pm

The game module is based on the movie module so that's why it is also slow. I'll have to check why they are so slow when I get home. But 1 minute is way too much!


Return to “1.0.8”

Who is online

Users browsing this forum: No registered users and 1 guest