1.0.8.1 patch-3, downloaded imdb-covers are broken.

everything about the previous stable version

Moderator: Moderator

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

1.0.8.1 patch-3, downloaded imdb-covers are broken.

Postby acmelabs » Thu Nov 16, 2006 12:50 am

hi,
I've tried to update the imdb-informations for the movie-covers, but they are all broken. can't either open it with a viewer.

Then I've looked inside a jpg with vi. And that's in it - strange!

Muenchen_cover.jpg:

Code: Select all

swfRE = new RegExp("^http://[^/]*\.imdb\.com/");
swfSTR = new String(swfSRC);
if ((swfDIVID)) {
        if ((document.all)) {
                swfDIV = document.all[swfDIVID];
        } else if ((document.getElementById)) {
                swfDIV = document.getElementById(swfDIVID);
        }
}
if ((swfDIV) && swfSTR.match(swfRE)) {
        var swfHTML = '<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" width="'+swfWIDTH+'" height="'+swfHEIGHT+'" id="'+swfID+'" align="'+swfALIGN+'">';
        swfHTML = swfHTML + '<param name="movie" value="'+swfSRC+'">';
        if ((swfARGS)) {
                var args = swfARGS;
                for (var i=0; i<args.length; i+=2) {
                        swfHTML = swfHTML + '<param name="'+args[i]+'" value="'+args[i+1]+'">';
                }
        }
        swfHTML = swfHTML + '<embed src="'+swfSRC+'" width="'+swfWIDTH+'" height="'+swfHEIGHT+'" id="'+swfID+'" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" align="'+swfALIGN+'"';
        if ((swfARGS)) {
                var args = swfARGS;
                for (var i=0; i<args.length; i+=2) {
                        swfHTML = swfHTML + ' '+args[i]+'="'+args[i+1]+'" ';
                }
        }
        swfHTML = swfHTML + '</embed></object>';
        swfDIV.innerHTML = swfHTML;
}

can anybody confirm?

Regards,

Andreas

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Mon Nov 20, 2006 7:50 pm

I can confirm that the movie München is not working. I'm not really sure what is wrong. It doesn't have a lot of information so that might be what is throwing the download thing off. The only problems seems to be downloading the cover, but then again, there is no real cover.

If you are talking about Munich, as in the one from 2005, then that one works fine here.

ajd
Posts: 68
Joined: Mon Mar 20, 2006 8:16 pm

Postby ajd » Sat Nov 25, 2006 7:17 am

I confirm. I got the weird code in the jpg file for "The Queen" http://us.imdb.com/title/tt0436697/, but it only happened once. I tried to duplicate it but now I'm getting empty (size 0) cover files when I do IMDb searches. This is happening now for all files. I'm using 1.0.8.1-patch 11.

Update-
Just tried regetting the covers with my fully patched 1.0.8 (which worked before) and it's giving me the same problem (size 0 jpgs) too! And likewise with 1.0.9. At this point none of the versions on my development system will download movie covers.

?!?!?!

I get this in the terminal when I quit mms

Code: Select all

Config: Opening configuration file /etc/mms/config
Using /etc/mms/ as configuration directory
loading last saved playlist
01:35:33 URL:http://us.imdb.com/find?q=CasinoRoyale2006;s=tt [11981] -> "/tmp/mms/wget-temp" [1]
01:35:38 URL:http://us.imdb.com/find?q=CasinoRoyale;s=tt [12857] -> "/tmp/mms/wget-temp" [1]
01:35:42 URL:http://us.imdb.com/title/tt0381061/ [53688] -> "/tmp/mms/wget-temp" [1]
01:35:43 URL:http://us.imdb.com/title/tt0381061/plotsummary [24413] -> "/tmp/mms/wget-temp" [1]
: Unsupported scheme.
Render: The image /usr/local/share/mms/movies/Casino_Royale_2006_cover.jpg could not be loaded



Somewhat confused... :?

ajd

ajd
Posts: 68
Joined: Mon Mar 20, 2006 8:16 pm

Postby ajd » Sat Nov 25, 2006 7:45 am

I've just checked my untouched, previously working, production system and IMDb covers are broken there too. DId IMDb do a site redesign that broke this feature?

Cheers,
ajd

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Sat Nov 25, 2006 5:43 pm

I'll set it as 'unproofed' on the buglist, until we get it clear

Lg
Roman

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Postby acmelabs » Sat Nov 25, 2006 7:39 pm

Uatschitchun wrote:I'll set it as 'unproofed' on the buglist, until we get it clear

Lg
Roman

Hi,
I ask myself, whether this feature with these movie covers is future-proof at all.
This feature is really bombastic, as long as it's working, but we do rely here on a single source with the hope the interface will nerver change. Is that really realistic?

Regards,

Andreas

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Sun Nov 26, 2006 2:01 pm

Fixed in patch-12. Thanks!

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Sun Nov 26, 2006 5:26 pm

Maybe Anders could give a hint on how to debug/reproduce this (or other) errors related to imdb-download!?

If we have debugging this a little easier fixing will certainly be easier, too!?

Maybe we can than add a littlie "debug-howto" to the wiki as a 'What to do when cover download is not working as it should' and give more users the possibility to debug ... the more users giving straight hints on what is going wrong, the more "future-proof it will get ... Is that realistic?

Lg
Roman

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Sun Nov 26, 2006 5:36 pm

The problem is that we are parsing pages from imdb directly. This means that each time they make changes to the site, the parser needs to be updated. Normally what companies do is to provide this data in a machine readable form so that the amount of changes is minimized.

Anyway I don't think there is much to do about it. Creating a library would help a bit on this. It is the right thing to do but it's all a matter of time :x

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Sun Nov 26, 2006 5:42 pm

Did test imdb download .. and getting this for some:

Code: Select all

18:31:41 URL:http://us.imdb.com/find?q=Angst;s=tt [30083] -> "/var/cache/mms/wget-temp" [1]
...
18:31:58 URL:http://us.imdb.com/title/tt0211919/ [46550] -> "/var/cache/mms/wget-temp" [1]
: Nicht unterstütztes Schema.
Render: Das Bild /usr/local/share/mms/movies/Angst_cover.jpg konnte nicht geladen werden
...
18:33:09 URL:http://us.imdb.com/find?q=African+Queen;s=tt [17439] -> "/var/cache/mms/wget-temp" [1]
...
18:34:00 URL:http://us.imdb.com/title/tt0043265/ [54035] -> "/var/cache/mms/wget-temp" [1]


and a second one:

Code: Select all

18:41:34 URL:http://us.imdb.com/title/tt0477800/ [39023] -> "/var/cache/mms/wget-temp" [1]
: Nicht unterstütztes Schema.
Render: Das Bild /usr/local/share/mms/movies/o_cover.jpg konnte nicht geladen werden


If I would only know how to check _why_ it is going wrong ;)

So, how did you get a result on the differing changes?

Lg
Roman

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Sun Nov 26, 2006 10:10 pm

Fixed the last one in patch-16. It's because they have no covers.


Return to “1.0.8”

Who is online

Users browsing this forum: No registered users and 1 guest