problem with movie playback in mms window

everything about the current big update and the latest stable branch

Moderator: Moderator

helian
Posts: 6
Joined: Wed Apr 09, 2008 5:28 pm

problem with movie playback in mms window

Postby helian » Wed Mar 04, 2009 12:43 pm

Hi,

when playing movies with mplayer inside mms screen, after sometime, 20 to 30 minutes, mplayer freezes and logs the error message

mplayer: poll timed out in MPlayerControl (hugh?)

after this, it stops accepting commands and I need to restart mms. I'm using rev. 2096, compiled with "--enable-alsaplayer --disable-epg --enable-gst-audio" and slackware 12.1

Any ideas on how to fix it ?




-helian

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Re: problem with movie playback in mms window

Postby Uatschitchun » Wed Mar 04, 2009 3:09 pm

movie playing inside MMS is buggy and therefor not supported ... Anders wanted to completly remove it ;)

But maybe there's a solution.
Lg
Roman

helian
Posts: 6
Joined: Wed Apr 09, 2008 5:28 pm

Re: problem with movie playback in mms window

Postby helian » Wed Mar 04, 2009 3:56 pm

I really like/need it, since I can't disable my TV overscan playing inside mms was the only solution I could find to watch movies in
fullscreen. I will take a look at the code later and see if I can fix it.

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Re: problem with movie playback in mms window

Postby arj » Thu Mar 05, 2009 8:26 am

The biggest problem is that mplayer is buggy. If one says to it: --noinput and --slave, it will still eat input from X11.


Return to “1.1.x”

Who is online

Users browsing this forum: No registered users and 3 guests