Page 1 of 1

Hollywood Plus Fifo still full

Posted: Thu Mar 19, 2009 10:20 pm
by naicheben
I wonder if one of you had the same problem. I tried all three microcode.bin from Sigmas Win98 Driverpack. But one issues while insmod something about dicom not function and the two others work, but not that nice. Sometimes playback stops with Errormessages about Fifo still being full. So I tried other cache values with mplayer. Best one was: mplayer -cache 2048 -framedrop -vo dxr3:prebuf:sync:norm=3 /path/to/file on the console and it works from mms as well, but with named error.

I'm running out of ideas were to search for a solution, so any hint is highly wellcome.


Re: Hollywood Plus Fifo still full

Posted: Tue Sep 07, 2010 9:20 pm
by Midas

i do not have a perfect solution but a little patch and my experiences to share.

My vdr suffers heavily from these error messages. Usually this happens if the OSD remains open too long or you zap through the submenus quite fast. Afaik this happens because the memory and capabilities of the dxr3 are too small to provide a common OSD. One workaround is to take another skin than eg st:tng (or the even bigger themes), in fact with skinelchi there are less crashes which lead to restart of vdr (fatal to recordings). Another way is to stay in the OSD as short as possible or close the OSD as fast as possible if you see it breaking down. Still do not know if i tell you anything new btw ;), just keep in mind that it is maybe some OSD by mplayer causing this error for you. Btw, i never experienced these errors while watching h264-mkvs (through vdr via mplayer-plugin) which were produced from vdr-recordings with quality settings (default?) in StaxRip under Windows.

Since these cli options were relatively new to me the only thing i can tell is that the sync option makes the mplayer stutter heavily on my machine, so it might be worth a try to leave this out. Clearly this is hardware-dependant because the driver tries to synchronize the em8300 timer with the mainboard timer iirc. Usually i also leave out the norm option which makes mplayer take the default (which is 0?). Furthermore i add -cache 8192, -framedrop and -ao alsa as well as -nocorrect-pts to the command line. While alsa helped me with some short stutters and probs the last option seems to do quite some more (eg prevents mplayer completely from grumbling at every single frame...). But as i am still experimenting with these, i guess mplayer is witchcraft...

Ok i played around a bit with the driver sources and it turned out that making the card sleep for a second in these cases made the OSD/vdr crash less often though it unfortunately still keeps crashing. If you check this out, please drop me a line if it helped.

Code: Select all

--- /Downloads/em8300-0.18.0/modules/em8300_fifo.c      2009-12-20 23:24:55.000000000 +0100
+++ em8300_fifo.c       2010-01-17 16:51:16.000000000 +0100
@@ -270,7 +270,12 @@
                                        else if (ret == 0) {
                                                printk("em8300-%d: Fifo still full, trying stop\n", fifo->em->card_nr);
                                                em8300_video_setplaymode(em, EM8300_PLAYMODE_STOPPED);
+                                               printk("em8300-%d: em8300_fifo.c: crash workaround #1\n", fifo->em->card_nr);
+                                               printk("em8300-%d: Playmode stopped.\n", fifo->em->card_nr);
+                                               printk("em8300-%d: Sleeping 1 second.\n", fifo->em->card_nr);
+                                               msleep(1000);
                                                em8300_video_setplaymode(em, EM8300_PLAYMODE_PLAY);
+                                               printk("em8300-%d: Playmode started.\n", fifo->em->card_nr);
                                        } else
                                                return (total_bytes_written>0) ? total_bytes_written : ret;

You could also try out another branch of the driver, published by the developer of the dxr3-plugin for vdr, which could be found somewhere here: But iirc this also did not solve the problem either.

A very interesting fact is that during the mms install last weekend i managed it to get the xinelibout-plugin running with the dxr3 and xine as frontend for vdr. In this config the OSD crashes are gone. I'll keep observing that... Unfortunately this far i couldn't manage to make xine play those mp4 or whatever through the dxr3 as it complains the well known error about only MPEG1-YUV420 supported. It would be great if someone could give me hint concerning this btw.

My Hollywood+ has an ADV7170 btw and i am running Debian lenny with Kernels 2.6.26-i686 and 2.6.28-i486 from the e-tobi repo and the latest driver 0.18.0 and i am uploading microcode 2d.

Though this was quite much vdr-related i hope it is of some help.

Up the irons


PS: Argh, first post here and also the first time for me at all to expose necrophilic tendencies, sry :o. I promise next time i will parse the date correctly...

Re: Hollywood Plus Fifo still full

Posted: Wed Sep 08, 2010 8:47 pm
by lorenzodes
Midas wrote:PS: Argh, first post here and also the first time for me at all to expose necrophilic tendencies, sry :o. I promise next time i will parse the date correctly...

Eh eh :)

Welcome by the way :)

Re: Hollywood Plus Fifo still full

Posted: Sat Sep 11, 2010 9:12 am
by Uatschitchun
Nice post!

Are you trying to play movies through VDR & xineliboutput?

What if you play them with MMS (mplayer, xine)?

Re: Hollywood Plus Fifo still full

Posted: Tue Sep 14, 2010 10:32 pm
by Midas
Hi Uatschitchun,

now i tried playing the movies via xinelibout+vdr, though the result was sort of expectable: the frontend (cxfe) crashed ;).

Playing via mplayer and vdr does the quite well though there could be audio sync probs from time to time, as well as sometimes there are video stutters resulting in people 'headbanging' in the movies :).

Playing the movies via mms (via mplayer/cxfe) or xine standalone results in very much the same. As described the xinelib suffers from MPEG1 - only YUV420 is supported error so every xine-related player would crash. I did not find the time this far to recompile xine with rte and/or fame of which it is rumored these would solve the problem. Unfortunately the source i found is quite outdated...

Hope this answered your question. ;)