S100 IEGD mplayer with xvmc ?

Configuration issues with S100 STBs

Moderator: Moderator

User avatar
naicheben
Overlord
Posts: 1332
Joined: Tue Apr 04, 2006 12:50 pm
Location: Germany/Leck
Contact:

S100 IEGD mplayer with xvmc ?

Postby naicheben » Wed Jul 15, 2009 11:18 pm

Hi folks, I bang my head on the desk! Need all of your help before I go mad!

I don't understand how to enable XvMC in Debian Etch/Lenny based on Mikkas Script.
In the xorg.conf I tried

Code: Select all

        Option          "XvMCSurfaces" "7"      # 6/7 for i810/i815 chipsets only, otherwise
                                                # XvMC is disabled.
        Option          "XvMC"  "true"          # enable XvMC chipsets after i815
        Option "Config/0/General/XVideoMC" "1"                                        # for TV-Out via FS454
        Option          "UseEvents" "true"
        Option     "AccelMethod"   "XAA"

I have XvMCConfig pointing at the library

Code: Select all

smiley:~# cat /etc/X11/XvMCConfig
/usr/lib/libXvMC.so.1
smiley:~# ls -ali /usr/lib/libXvMC.so.1
18707 lrwxrwxrwx 1 root root 16 2009-03-02 16:17 /usr/lib/libXvMC.so.1 -> libXvMC.so.1.0.0

And I compiled mplayer with xvmc support

Code: Select all

smiley:~# mplayer -vo help
MPlayer SVN-r29418-4.1.2 (C) 2000-2009 MPlayer Team
Available video output drivers:
        xv      X11/Xv
        x11     X11 ( XImage/Shm )
        xover   General X11 driver for overlay capable video output drivers
        gl      X11 (OpenGL)
        gl2     X11 (OpenGL) - multiple textures version
        sdl     SDL YUV/RGB/BGR renderer (SDL v1.1.7+ only!)
        fbdev   Framebuffer Device
        fbdev2  Framebuffer Device
        dxr3    DXR3/H+ video out
        xvidix  X11 (VIDIX)
        cvidix  console VIDIX
        null    Null video output
        xvmc    XVideo Motion Compensation
        mpegpes MPEG-PES to DVB card
        yuv4mpeg        yuv4mpeg output for mjpegtools
        png     PNG file
        jpeg    JPEG file
        gif89a  animated GIF output
        tga     Targa output
        pnm     PPM/PGM/PGMYUV file
        md5sum  md5sum of each frame


If I play a movie I dont get the video but I can hear the sound. The logs say no video vo found.

What are these XvMCSurfaces for? One can choose between 6 and 7. But what is it? 6 or 7 X-Surfaces or mplayer-threads or Video heads? What do I have to put in and why? I found a very nice looking Howto here: http://www.mythtv.org/wiki/XvMC#Intel_8xx.2F9xx but that did not help me either.

So please, if anyone ever managed to use XvMC on the s100, please tell me were to search for the fault/mistake I make.
mit Hellseherschein ;.)

Return to “S 100”

Who is online

Users browsing this forum: No registered users and 2 guests