Undefined symbol ?!

Discussion about user contributed plugins

Moderator: Moderator

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Undefined symbol ?!

Postby Uatschitchun » Mon May 19, 2008 12:30 pm

Getting this one when trying my debs in gutsy-vm:

Traceback (most recent call last):
File "/usr/share/mms/scripts/youtube/youtube.py", line 1, in <module>
import mmsv2gui, mmsv2
ImportError: /usr/lib/python2.5/site-packages/mmsv2.so: undefined symbol: _ZN5Movie9MovieOpts12movie_playerEv
Error in sys.excepthook:
Traceback (most recent call last):
File "/var/lib/python-support/python2.5/apport_python_hook.py", line 42, in apport_excepthook
binary = os.path.realpath(os.path.join(os.getcwdu(), sys.argv[0]))
AttributeError: 'module' object has no attribute 'argv'

Original exception was:
Traceback (most recent call last):
File "/usr/share/mms/scripts/youtube/youtube.py", line 1, in <module>
import mmsv2gui, mmsv2
ImportError: /usr/lib/python2.5/site-packages/mmsv2.so: undefined symbol: _ZN5Movie9MovieOpts12movie_playerEv
PyRun_SimpleFile return -1
Terminating inotify...Done

:?:
Lg
Roman

lorenzodes
master
Posts: 772
Joined: Sun Mar 11, 2007 4:50 pm
Location: move.l 4.w,a6

Postby lorenzodes » Mon May 19, 2008 12:40 pm

We need to see the compilation options.
"I’m not frightened of dying, anytime will do, I don’t mind. Why should I be frightened of dying? There’s no reason for it, you gotta go sometime"

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Mon May 19, 2008 2:15 pm

Here you are:
./configure --prefix=/usr --enable-lirc --enable-evdev --enable-ffmpeg-thumb --enable-notify-area --enable-gst-audio --enable-xine-audio --enable-opengl --enable-dxr3 --enable-dvb --enable-mpeg --enable-lcd --enable-game --enable-tv --enable-weather --enable-python --enable-clock --enable-vbox --disable-optimization
Lg

Roman

Fredde
veteran
Posts: 288
Joined: Tue Dec 06, 2005 7:18 am
Location: Sweden

Re: Undefined symbol ?!

Postby Fredde » Mon May 19, 2008 2:23 pm

Uatschitchun wrote:Getting this one when trying my debs in gutsy-vm:
...

Seems to be some error in linking. The python plugin use mms movie code to play movies. Will investigate further.

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Mon May 19, 2008 3:58 pm

Getting this:
libtool: link: warning: `-L' is ignored for archives/objects
Lg

Roman

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Mon May 19, 2008 5:29 pm

The warning is harmless. Can you see if the movie plugin was loaded before the python one? It should say so in the console.

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Mon May 19, 2008 5:33 pm

It's without movie plugin ;)

It's from the debs with only core, clock, audio, python
Lg

Roman

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Mon May 19, 2008 5:37 pm

Ah

that explains it then :D


Return to “user plugins”

Who is online

Users browsing this forum: No registered users and 3 guests