Notes on mms ppa-install for lucid x86_64 & HowTo

Moderator: Moderator

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Notes on mms ppa-install for lucid x86_64 & HowTo

Postby acmelabs » Sat Apr 23, 2011 11:42 am

Hi,

just installed on an Ubunut 10.04 x86_64 (Lucid) Romans PPA MMS package.

Code: Select all

sudo apt-get install python-software-properties
aptitude update
sudo add-apt-repository  ppa:mms-prodeia/ppa
apt-get install mms mms-...

All worked fine. The only think made me compile again, was the broken internal thumbnailer (swScaler Problem, see log below).

Simple MMS howto for Lucid

Code: Select all

mkdir mms && cd mms
wget http://mms.mymediasystem.net/mms110/nightly-snapshot/mms-1.1.0-2272.tgz
apt-get build-dep mms
apt-get install  checkinstall
tar xfvz mms-1.1.0-2272.tgz
cd mms-1.1.0-2272
./configure  --use-internal-ffmpeg --enable-debug --enable-tv --enable-game --enable-weather --enable-notify-area --enable-clock --enable-python --enable-lirc --enable-clock --disable-inotify --enable-alsaplayer --disable-ffmpeg-thumb --enable-rip
make -j4
checkinstall
dpkg -i  mms-1.1.0_2272-1_amd64.deb

Change your Resolution and Input-Method in /etc/mms/Config, and add your paths for your Pictures, Movies and Weather Locations in /etc/mms/MovieConfig, /etc/mms/PictureConfig, /etc/mms/WeatherConfig.
Start it in your language e.g. like this:

Code: Select all

LANG=de_DE.UTF-8 mms


Here's the log for the broken thumbs:

Code: Select all

.
.
.
h264 @ 0x7fc734103290]number of reference frames exceeds max (probably corrupt input), discarding one
    Last message repeated 417 times
[h264 @ 0x7fc734103290]mmco: unref short failure
    Last message repeated 1 times
[h264 @ 0x7fc734103290]number of reference frames exceeds max (probably corrupt input), discarding one
swScaler: xvmcmc is not supported as output pixel format
MMS Player: <createthumbnail> Could not create SWScale context
[mpeg2video @ 0x7fc73402fae0]warning: first frame is no keyframe
swScaler: xvmcmc is not supported as output pixel format
MMS Player: <createthumbnail> Could not create SWScale context
[matroska @ 0x7fc7341059d0]Unknown entry 0xEA
[matroska @ 0x7fc7341059d0]Unknown entry 0xA4
[matroska @ 0x7fc7341059d0]Estimating duration from bitrate, this may be inaccurate
[mpeg2video @ 0x7fc734595750]warning: first frame is no keyframe
swScaler: xvmcmc is not supported as output pixel format
MMS Player: <createthumbnail> Could not create SWScale context
[matroska @ 0x7fc7341059d0]Estimating duration from bitrate, this may be inaccurate
swScaler: xvmcmc is not supported as output pixel format
MMS Player: <createthumbnail> Could not create SWScale context
[matroska @ 0x7fc734211d80]Estimating duration from bitrate, this may be inaccurate
swScaler: xvmcmc is not supported as output pixel format
MMS Player: <createthumbnail> Could not create SWScale context
[matroska @ 0x7fc734211d80]max_analyze_duration reached
[matroska @ 0x7fc734211d80]Estimating duration from bitrate, this may be inaccurate
swScaler: xvmcmc is not supported as output pixel format
MMS Player: <createthumbnail> Could not create SWScale context
[matroska @ 0x7fc734211d80]max_analyze_duration reached
[matroska @ 0x7fc734211d80]Estimating duration from bitrate, this may be inaccurate
swScaler: xvmcmc is not supported as output pixel format
MMS Player: <createthumbnail> Could not create SWScale context
[matroska @ 0x7fc734211d80]Estimating duration from bitrate, this may be inaccurate
swScaler: xvmcmc is not supported as output pixel format
MMS Player: <createthumbnail> Could not create SWScale context
[matroska @ 0x7fc734211d80]Estimating duration from bitrate, this may be inaccurate
swScaler: xvmcmc is not supported as output pixel format
MMS Player: <createthumbnail> Could not create SWScale context
.
.
.


And the version in mms-theme-ocean (theme.conf) should be increased by one (=39), else it won't start.
In /etc/mms/MovieConfig the setting "information_source=english" doesn't work. "german" is working fine.

PS: Tried XBMC (Dharma) on my every-year-basis, and it's still not usable in a productive environment. Gues I'll stik to MMS for good :)

mtron
Posts: 13
Joined: Wed Jul 29, 2009 12:17 pm

Re: Notes on mms ppa-install for lucid x86_64 & HowTo

Postby mtron » Sun May 01, 2011 7:44 pm

finally got the thumbs in mms back :)

Thanks a lot!


Return to “general discussion”

Who is online

Users browsing this forum: No registered users and 3 guests