(SOLVED) Images in cache are always re-built

other problems with configuration of mms

Moderator: Moderator

User avatar
wolfgang18
Posts: 31
Joined: Thu Apr 23, 2009 6:42 am
Location: Germany - Southern Bavaria

(SOLVED) Images in cache are always re-built

Postby wolfgang18 » Mon Jun 08, 2009 7:22 pm

Hi all!
I have one problem with my S100 / debvision installation. Since I have moved almost all movies to a NAS and access them via CIFS share, browsing my movies folder is extremely slow, although I configured this folder as "no_watch" to avoid inotify trouble. However, it seems that the cache images are rebuilt each time. I can see this in my cache folder (/var/cache/mms/mnt/disc/movies/...) where the images are listed several times (having a different timestamp/numbers).
I have checked write access to the cache and cleaning it did also not help. In the movie dir, choosing "list" mode (instead of icon mode) I see that the codec is of "type 85" for some of the files. Even in list mode it takes seconds 7half a minute to step from one movie to the other. Whenever I choose the image from IMDB this works fine with this item.

Can anybody help me?
Last edited by wolfgang18 on Tue Aug 04, 2009 6:38 am, edited 1 time in total.
S100, 30GB HDD, USB HDD, Debvision_Etchbox_Community_2, MMS 1.1.1
S100, 4GB SD-CARD System with NAS, Debian Lenny, MMS 1.1.1

lorenzodes
master
Posts: 772
Joined: Sun Mar 11, 2007 4:50 pm
Location: move.l 4.w,a6

Re: Images in cache are always re-built

Postby lorenzodes » Tue Jun 09, 2009 3:28 pm

What revno of mms?
"I’m not frightened of dying, anytime will do, I don’t mind. Why should I be frightened of dying? There’s no reason for it, you gotta go sometime"

User avatar
wolfgang18
Posts: 31
Joined: Thu Apr 23, 2009 6:42 am
Location: Germany - Southern Bavaria

Re: Images in cache are always re-built

Postby wolfgang18 » Tue Jun 09, 2009 6:02 pm

Code: Select all

etchbox:~# mms -V
My Media System: 1.1.1
Configuration: --prefix=/usr --enable-lirc --enable-evdev --enable-notify-area --enable-res-switch --enable-gst-audio --enable-alsaplayer --enable-opengl --enable-dxr3 --enable-dvb --enable-mpeg --enable-lcd --enable-game --enable-tv --enable-weather --enable-python --enable-clock --enable-vbox --enable-debug --disable-optimization --use-internal-ffmpeg


It's from the latest 1.1.1 debs from Roman. I use this in Debvision CR2
S100, 30GB HDD, USB HDD, Debvision_Etchbox_Community_2, MMS 1.1.1
S100, 4GB SD-CARD System with NAS, Debian Lenny, MMS 1.1.1

lorenzodes
master
Posts: 772
Joined: Sun Mar 11, 2007 4:50 pm
Location: move.l 4.w,a6

Re: Images in cache are always re-built

Postby lorenzodes » Tue Jun 09, 2009 6:06 pm

wolfgang18 wrote:It's from the latest 1.1.1 debs from Roman. I use this in Debvision CR2


Then I guess recompiling mms is a no-option for you?

Anyway, does it happen for all the thumbnails or only for some?

When you say "where the images are listed several times (having a different timestamp/numbers)", what numbers are you referring to? Numbers in the name?
"I’m not frightened of dying, anytime will do, I don’t mind. Why should I be frightened of dying? There’s no reason for it, you gotta go sometime"

User avatar
wolfgang18
Posts: 31
Joined: Thu Apr 23, 2009 6:42 am
Location: Germany - Southern Bavaria

Re: Images in cache are always re-built

Postby wolfgang18 » Wed Jun 10, 2009 5:38 am

I could do a recompile on my second S100 system which I set up currently (if the problem occurs there, too). This might take a while ...
The problem seems to affect all thumbnails dynamically created from screenshots inside the movie. As a workaround I have started to download movie covers to avoid the thmubnailing procedure everytime I enter the movie dir. At the moment I have no access to the system but as I recall, there were several files in the cache like

Code: Select all

a_quantum_solace_130823213098_1385.jpg
a_quantum_solace_230546321304_1385.jpg
...


Could this be a problem of the movie.db? I have cleaned the cache dirs several times, but nothing else .... (hint: The files where on the local disk once and I moved them to the network storage)
S100, 30GB HDD, USB HDD, Debvision_Etchbox_Community_2, MMS 1.1.1
S100, 4GB SD-CARD System with NAS, Debian Lenny, MMS 1.1.1

lorenzodes
master
Posts: 772
Joined: Sun Mar 11, 2007 4:50 pm
Location: move.l 4.w,a6

Re: Images in cache are always re-built

Postby lorenzodes » Wed Jun 10, 2009 11:18 am

wolfgang18 wrote:I could do a recompile on my second S100 system which I set up currently (if the problem occurs there, too). This might take a while ...
The problem seems to affect all thumbnails dynamically created from screenshots inside the movie. As a workaround I have started to download movie covers to avoid the thmubnailing procedure everytime I enter the movie dir. At the moment I have no access to the system but as I recall, there were several files in the cache like

Code: Select all

a_quantum_solace_130823213098_1385.jpg
a_quantum_solace_230546321304_1385.jpg
...


Could this be a problem of the movie.db? I have cleaned the cache dirs several times, but nothing else .... (hint: The files where on the local disk once and I moved them to the network storage)


Nope. The name of a thumbnail is generated using the path/name of the movie file plus its modification time plus the size of the thumbnail in pixels (e.g. 172X141 becomes 172_41). If the modification time of the movie file changes (i.e. if the movie file changes or it is "touched"), the thumbnail is regenerated. If the thumbnail size is not suitable for the current screen resolution, again, the thumbnail is regenerated.

Post real file names please :)
"I’m not frightened of dying, anytime will do, I don’t mind. Why should I be frightened of dying? There’s no reason for it, you gotta go sometime"

User avatar
wolfgang18
Posts: 31
Joined: Thu Apr 23, 2009 6:42 am
Location: Germany - Southern Bavaria

Re: Images in cache are always re-built

Postby wolfgang18 » Wed Jun 10, 2009 6:42 pm

OK, a real-life example:

mount ...

Code: Select all

//192.168.178.100/mms on /mnt/disc type smbfs (rw)

and there:

Code: Select all

-rwxr-xr-x 1 root root 1033930066 2009-03-25 02:31 Bube dame Koenig GrAs.avi


an the cache in /var/cache/mms/mnt/disc/movies/:

Code: Select all

-rw-r--r-- 1 vision vision 4695 2009-06-08 21:05 Bube dame Koenig GrAs_1237919472_185_138.jpg
-rw-r--r-- 1 vision vision 4695 2009-06-08 21:06 Bube dame Koenig GrAs_1237923072_185_138.jpg
-rw-r--r-- 1 vision vision 3019 2009-06-08 21:07 Bube dame Koenig GrAs_1237926672_129_117.jpg
-rw-r--r-- 1 vision vision 3019 2009-06-08 21:14 Bube dame Koenig GrAs_1237930272_129_117.jpg
-rw-r--r-- 1 vision vision 4695 2009-06-08 21:16 Bube dame Koenig GrAs_1237933872_185_138.jpg
-rw-r--r-- 1 vision vision 4695 2009-06-09 21:31 Bube dame Koenig GrAs_1237937472_185_138.jpg


Can i try anything else? How do I manually generate the thumbs? Perhaps I can collect more infos ...
S100, 30GB HDD, USB HDD, Debvision_Etchbox_Community_2, MMS 1.1.1
S100, 4GB SD-CARD System with NAS, Debian Lenny, MMS 1.1.1

lorenzodes
master
Posts: 772
Joined: Sun Mar 11, 2007 4:50 pm
Location: move.l 4.w,a6

Re: Images in cache are always re-built

Postby lorenzodes » Wed Jun 10, 2009 6:59 pm

wolfgang18 wrote:

Code: Select all

-rw-r--r-- 1 vision vision 4695 2009-06-08 21:05 Bube dame Koenig GrAs_1237919472_185_138.jpg
-rw-r--r-- 1 vision vision 4695 2009-06-08 21:06 Bube dame Koenig GrAs_1237923072_185_138.jpg
-rw-r--r-- 1 vision vision 3019 2009-06-08 21:07 Bube dame Koenig GrAs_1237926672_129_117.jpg
-rw-r--r-- 1 vision vision 3019 2009-06-08 21:14 Bube dame Koenig GrAs_1237930272_129_117.jpg
-rw-r--r-- 1 vision vision 4695 2009-06-08 21:16 Bube dame Koenig GrAs_1237933872_185_138.jpg
-rw-r--r-- 1 vision vision 4695 2009-06-09 21:31 Bube dame Koenig GrAs_1237937472_185_138.jpg


Can i try anything else? How do I manually generate the thumbs? Perhaps I can collect more infos ...


Can you please check the original movie file, "Bube dame Koenig GrAs", and see its modification time?
"I’m not frightened of dying, anytime will do, I don’t mind. Why should I be frightened of dying? There’s no reason for it, you gotta go sometime"

User avatar
wolfgang18
Posts: 31
Joined: Thu Apr 23, 2009 6:42 am
Location: Germany - Southern Bavaria

Re: Images in cache are always re-built

Postby wolfgang18 » Wed Jun 10, 2009 7:11 pm

Something strange happening here I guess:
using ls -lu Bub*

I get

Code: Select all

-rwxr-xr-x 1 root root 1033930066 2009-06-09 01:00 Bube dame Koenig GrAs.avi

( a lot of movies - not all - have exactly the same date/time ...)

I'm sure I haven't done anything with this file... Does mms touch it? Perhaps I shal ltry mounting this share ro ....
However, I admit, this is a very "silly" NAS relying on FAT32 fs...
S100, 30GB HDD, USB HDD, Debvision_Etchbox_Community_2, MMS 1.1.1
S100, 4GB SD-CARD System with NAS, Debian Lenny, MMS 1.1.1

lorenzodes
master
Posts: 772
Joined: Sun Mar 11, 2007 4:50 pm
Location: move.l 4.w,a6

Re: Images in cache are always re-built

Postby lorenzodes » Wed Jun 10, 2009 7:18 pm

wolfgang18 wrote:Something strange happening here I guess:
using ls -lu Bub*

I get

Code: Select all

-rwxr-xr-x 1 root root 1033930066 2009-06-09 01:00 Bube dame Koenig GrAs.avi

( a lot of movies - not all - have exactly the same date/time ...)

I'm sure I haven't done anything with this file... Does mms touch it? Perhaps I shal ltry mounting this share ro ....
However, I admit, this is a very "silly" NAS relying on FAT32 fs...



No, mms opens it in read only mode. Also, considering only root have write access, mms couldn't write to that file even if it wanted to.
"I’m not frightened of dying, anytime will do, I don’t mind. Why should I be frightened of dying? There’s no reason for it, you gotta go sometime"

User avatar
wolfgang18
Posts: 31
Joined: Thu Apr 23, 2009 6:42 am
Location: Germany - Southern Bavaria

(SOLVED) Re: Images in cache are always re-built

Postby wolfgang18 » Tue Aug 04, 2009 6:37 am

So - finally I ended up with using another NAS - and it works now.
Mine was a Digitus DN7023 "Mini-NAS" - Do not use it with MMS videos!
Thanks lorenzodes for your patience ....
S100, 30GB HDD, USB HDD, Debvision_Etchbox_Community_2, MMS 1.1.1
S100, 4GB SD-CARD System with NAS, Debian Lenny, MMS 1.1.1


Return to “other”

Who is online

Users browsing this forum: No registered users and 1 guest