Sound with ac3 works, stereo not

other problems with configuration of mms

Moderator: Moderator

parti02
veteran
Posts: 232
Joined: Sat Jun 16, 2007 5:52 pm

Sound with ac3 works, stereo not

Postby parti02 » Sun Mar 16, 2008 10:05 am

Hi all,
i know this is not an mms problem, but perhaps someone have an idea.

I have an Terratec Aureon 5.1 pci card installed and connect it over spdif to a Teufel Decoder Station.
When i playing a video with ac3 sound everything is ok, but when i try
to play stereo i hear nothing. The light from my spdif out is dark!
Is it possible to send stereo over spdif? How?

Gruß
Dirk

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Re: Sound with ac3 works, stereo not

Postby acmelabs » Sun Mar 16, 2008 12:57 pm

parti02 wrote:Hi all,
i know this is not an mms problem, but perhaps someone have an idea.

I have an Terratec Aureon 5.1 pci card installed and connect it over spdif to a Teufel Decoder Station.
When i playing a video with ac3 sound everything is ok, but when i try
to play stereo i hear nothing. The light from my spdif out is dark!
Is it possible to send stereo over spdif? How?

Gruß
Dirk

Did you already played with all the different switches e.g. in alsaplayer?
it's working here over optical S/PDIF with ac3 5.1. and 2.0 (mp3/stereo?).

my switches are like this:
Image

Regards,
Andreas

parti02
veteran
Posts: 232
Joined: Sat Jun 16, 2007 5:52 pm

Postby parti02 » Mon Mar 17, 2008 6:51 pm

good to know that is possible, perhaps these are only probs with ubuntu hardy.

Thx Andreas

[wEm]
Posts: 11
Joined: Wed Dec 05, 2007 9:34 pm

Postby [wEm] » Wed Mar 19, 2008 8:05 am

Which Media player do you use for playback?

I've got the same audio card and ac3 as well as stereo works on my optical output using mplayer.

i've changed nothin in the config files, becaus if i add -ac hwac3 in MplayerCong, mplayer will have the same behaviour as your problem (playback ac3, but not stereo). I've removed the option hwac3 and everything works fine.

You could also try to set up the audio code in mplayer.conf (/etc/mplayer)
to ac = hwac3,

you MUST type the comma behind for it causes mplayer to use not hwac3 for not-ac3-sources.

Regards
Sascha
There's no justice, just ME! (Death)


Return to “other”

Who is online

Users browsing this forum: No registered users and 2 guests