howto disable DVB-s audio when playing mp3 [solved]

other problems with configuration of mms

Moderator: Moderator

prophecy
Posts: 10
Joined: Wed Nov 28, 2007 4:26 pm

howto disable DVB-s audio when playing mp3 [solved]

Postby prophecy » Fri Nov 30, 2007 6:25 pm

My mms now is working fine with vdr-externalplayer.

My (i hope) last problem is the sound output over DVB-s.
It is playing in background the tv sound, even when i am playing mp3s.
I plugged the Audio out from DVB to my line-in of my soundcard
and setup alsamixer for the line-in output.

Is there a way to stop the DVB audio when i launch mms or start playing mp3?
Disabling line-out by mms start and enabling it by mms stop would work too, maybe someone got a working script?
Last edited by prophecy on Mon Dec 03, 2007 5:04 pm, edited 1 time in total.

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Fri Nov 30, 2007 6:45 pm

What about sending an svdrpsendpl command when starting MMS to mute VDR and un-mute with MMS' shutdown_command?

Code: Select all

svdrpsend.pl HITK Mute
Lg
Roman

prophecy
Posts: 10
Joined: Wed Nov 28, 2007 4:26 pm

Postby prophecy » Fri Nov 30, 2007 6:52 pm

This would be great, but where can i enter the command?

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Sat Dec 01, 2007 8:57 am

Just put the svdrpsend commad in a script together with the call of MMS and give that script in externalplayer.conf

Else the reading of

Code: Select all

man amixer

should be helpful, too ;)
Lg

Roman

prophecy
Posts: 10
Joined: Wed Nov 28, 2007 4:26 pm

Postby prophecy » Mon Dec 03, 2007 1:48 pm

Now i tested it to mute via shell script

I created a script named mms-start.sh
with
/usr/lib/vdr/svdrpsend.pl HITK Mute
mms

and in externalplayer i start this script instead of mms

But this is not working...
the command from shell is ok with user root and vdr,
but after using it with externalplayer
svdrpsend.pl VOLU returns that the volume = mute
but the volume has not changed because i hear the sound

Maybe it has something to do with the keymapping from externalplayer?
(i use the remote of my FF DVB-s)

------------------------------------------------------------

So i changed my script (/etc/mms/mms-start.sh)
to mute my line-in

#!/bin/sh
amixer set Line mute
mms

and created a script (/etc/mms/mms-shutdown.sh)
to restore the line-in volume (unmute)

#!/bin/sh
amixer set Line unmute

Additionaly the shutdown script must be enabled in /etc/mms/config with

shutdown_script = "/etc/mms/mms-shutdown.sh"


With this changes mms is a really nice mp3 player
for local files and internet streams !
(And i have no longer the background sound of my DVB-s audio over line-in ...)


Return to “other”

Who is online

Users browsing this forum: No registered users and 1 guest