alsaplayer with mms over vdr-externalplayer [solved]

other problems with configuration of mms

Moderator: Moderator

prophecy
Posts: 10
Joined: Wed Nov 28, 2007 4:26 pm

alsaplayer with mms over vdr-externalplayer [solved]

Postby prophecy » Wed Nov 28, 2007 4:45 pm

Hi,

i have ct-vdr6 with externalplayer installed, output over ff-DVB-s and sound via alsaplayer.
When i start mms over externalplayer it shows me the music dir, creates a playlist but doesnt play my mp3s (it jumps really fast through all the tracks)

When i start mms as root from shell everything is fine and ist plays mp3s,
i set up a shell for user vdr and when i log in as vdr, mms is playing mp3s, too.

Does someone has a idea to solve my problem?
Last edited by prophecy on Fri Nov 30, 2007 2:49 pm, edited 2 times in total.

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Re: alsaplayer with mms over vdr-externalplayer problem

Postby acmelabs » Wed Nov 28, 2007 10:49 pm

prophecy wrote:Hi,

i have ct-vdr6 with externalplayer installed, output over ff-DVB-s and sound via alsaplayer.
When i start mms over externalplayer it shows me the music dir, creates a playlist but doesnt play my mp3s (it jumps really fast through all the tracks)

When i start mms as root from shell everything is fine and ist plays mp3s,
i set up a shell for user vdr and when i log in as vdr, mms is playing mp3s, too.

Does someone has a idea to solve my problem?


Could you tell us the permissions of an mp3 and/or of a folder they're in?

Thanks
Regards,
Andreas

prophecy
Posts: 10
Joined: Wed Nov 28, 2007 4:26 pm

Postby prophecy » Thu Nov 29, 2007 1:31 am

The mp3s are in a samba share,
owner: smbuser rwx
group: vdr rwx
other: rw

the files
owner: smbuser rwx
group: vdr r
other r

should be ok...

esprit
master
Posts: 503
Joined: Tue Dec 06, 2005 5:50 pm
Location: France
Contact:

Postby esprit » Thu Nov 29, 2007 9:46 am

isn't there already an alsaplayer running (launched by VDR ?) that prevents the one launched by mms to access the audio device ?

prophecy
Posts: 10
Joined: Wed Nov 28, 2007 4:26 pm

Postby prophecy » Thu Nov 29, 2007 11:50 am

Maybe there could be an running alsaplayer...
but on vdr the sound output comes from my ff-dvb-s card and not from the soundcard, and alsa output goes over the soundcard.
So there is no reason for alsa to run on vdr.

I dont belive that this is the reason, but when you tell me how to check it i can do it.

esprit
master
Posts: 503
Joined: Tue Dec 06, 2005 5:50 pm
Location: France
Contact:

Postby esprit » Thu Nov 29, 2007 12:02 pm

Just do a 'ps auxf' and look for alsaplayer process in the output

or do a lsof | grep /dev/snd

prophecy
Posts: 10
Joined: Wed Nov 28, 2007 4:26 pm

Postby prophecy » Thu Nov 29, 2007 12:33 pm

Ok, there is no alsa running!

I tried something different, i stopped vdr, logged in as user vdr
and started via "vdr start -P remote -P externalplayer"

And everything is fine ... i go on and test my other plugins,
maybe a plugin is the problem

... tested with all other plugins (without burn cause it wanted some extra options) and mms plays mp3

What is different when vdr is started automatically???

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Thu Nov 29, 2007 1:43 pm

If you set MMS debug to 3 in config, you should get the output within /tmp/vdr-err.???? files created by VDR ... that could be a first step. Syslog, etc. might be helpful, too!
Lg
Roman

prophecy
Posts: 10
Joined: Wed Nov 28, 2007 4:26 pm

Postby prophecy » Fri Nov 30, 2007 12:53 pm

With debug=3 i get those messages:

vdr: warning cannot set dumpabble: invalid argument
(many lines with)
input: something

imms: could not open x display (cause i got no x)
imms: disabling idleness detector
Invalid config file //.alsaplayer/config

Render: preparing new image file
...

Which config file is used? /root/.alsaplayer/config ???
This config file exists but is empty!

Ok, i edited the /etc/mms/config to start alsaplayer with -r -c /root/.alsaplayer/conf and it works fine!!!

But where should be //.alsaplayer/config ??
Then i can create this empty file and it should work without the -c option

esprit
master
Posts: 503
Joined: Tue Dec 06, 2005 5:50 pm
Location: France
Contact:

Postby esprit » Fri Nov 30, 2007 1:22 pm

probably you have not set : HOME neither USER

Just export this two variables before launching vdr or mms, and this should be OK.

export HOME=/home/vdr (or whatever it is)
export USER=vdr

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Fri Nov 30, 2007 2:22 pm

Nice you've got it solved!
Lg

Roman

prophecy
Posts: 10
Joined: Wed Nov 28, 2007 4:26 pm

Postby prophecy » Fri Nov 30, 2007 2:48 pm

This:
export HOME=/home/vdr (or whatever it is)
export USER=vdr
didn't work!

I dont like to use the /root/.alsaplayer/config,
so i created /etc/mms/.alsaplayer/config
and set in /etc/mms/config
alsaplayer_options = -r -c /etc/mms/.alsaplayer/config
(rwx for user vdr and group audio)

Its a bit stupid to prevent playing audio for a not found !empty! file...
so the solution is to create a empty file and -c it in mms config


Return to “other”

Who is online

Users browsing this forum: No registered users and 1 guest