Keyboard problem with mplayer

problems with keyboard, lirc or evdev

Moderator: Moderator

Hagbard23
Posts: 2
Joined: Mon Feb 20, 2006 8:52 am

Keyboard problem with mplayer

Postby Hagbard23 » Mon Feb 20, 2006 8:54 am

When i start a movie playback the keyboard doesnt work anymore with mplayer. I cant seek or stop the movie only watching works :/ Do i have to use lirc or does it work with keyboard only configuration too ?

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Mon Feb 20, 2006 8:31 pm

It should just work with keyboard. Did you compile with SDL output? Did you start mms in a special way (such as from a startup script at boot)?

Hagbard23
Posts: 2
Joined: Mon Feb 20, 2006 8:52 am

Postby Hagbard23 » Mon Feb 20, 2006 11:09 pm

Ive compiled it from gentoo ebuild with sdl support. im starting it as user with startx and the .xinitrc file. Menu works fine only mplayer doenst work.

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Tue Feb 21, 2006 9:34 pm

Strange. I just tried reproducing it here without luck.

It would really help you could post the output of mplayer. Could you post your config file?

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Keyboard with mplayer on single x session

Postby Uatschitchun » Mon May 29, 2006 12:09 pm

Would like to bring this back to topic ...

I try to get mms running on an old test-laptop.

Things working nice! I'm starting mms from within xterm on a seperate X-Server Display

Code: Select all

/usr/X11R6/bin/X :1 -ac & sleep 2; DISPLAY=:1 xterm -e mms &


Only thing not working is keyboard input for mplayer ;(
Videos playing fine (with xv, xvidix:mach64_vid.so, sdl) but I can't get one keystroke through !?

Does anyone have a config like this?
I know this thread:
http://mms.kicks-ass.org/forum/viewtopic.php?t=26&highlight=mplayer
but there's no conclusion ...

I know zenslack-distri is using mms and mplayer like this ... but with lirc/event input, not keyboard ...

LG
Roman

cxbell
Posts: 1
Joined: Mon Nov 05, 2007 3:00 pm
Location: Hampshire, UK
Contact:

Keyboard difficulties.

Postby cxbell » Mon Nov 05, 2007 3:07 pm

Hi, I'm having a similar problem

MMS installed from latest debian packages, no X11, running SDL. Movies play correctly (thus far) with sound, however I have no control over mplayer when a movie is played. All keyboard input seems to have stopped and is being cached before being handed over to MMS when the movie finishes playing.

So far MMS is the best of breed with the various Media Centers out there and I'd really like to finish off my media center running this software.


Here's hoping I can find a solution....

c


Return to “input”

Who is online

Users browsing this forum: No registered users and 2 guests