MMS (1.0.8.5) for Debian & Ubuntu (removed!)

Moderator: Moderator

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Postby acmelabs » Mon Jun 18, 2007 12:11 pm

Uatschitchun wrote:Just wanted to let you know that MMS was uploaded to Debian :P

It's now waiting in NEW for checks and get into Unstable then ...

http://ftp-master.debian.org/new.html

Excellent :D

R3gards
Andreas

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Mon Jun 18, 2007 2:12 pm

arj wrote:Will you still be able to track the number of downloads? :)

Not sure ;(

Maybe popcon (http://popcon.debian.org/) is able to provide data, but that's the only possibilty I am aware of! Too many mirrors :?
Lg
Roman

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Wed Jul 11, 2007 12:22 pm

Newest statistics, cause I will update to rc3 today ...

Image
Lg

Roman

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Wed Jul 11, 2007 12:55 pm

Bump cause of new version (rc3)

mms-slim (only package using gstreamer) had no dependency to gstreamer at all ... :oops:

Seems the 72 users were all using gnome :P
Lg

Roman

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Wed Jul 25, 2007 6:37 am

After a long time MMS was waiting in debian's NEW queue, it was processed yesterday ... but with no effort :roll:

Here's the mail with reasons, fyi:

Hi Maintainer,

rejected, for various reasons.

First - your debian/copyright, while already nice and large, still
misses information. Like - Vera.ttf copyright/license info is
different. Actually - it doesnt seem to be the usual Vera.ttf font but a
renamed old Frutiger-Bold one. (Look at it with less).

The second reason is the inclusion (and usage) of library stuff that is
already packaged in Debian. This is strongly discouraged, as it makes it
nearly impossible for the security team to do real security support.


Unless Anders has an idea on how to exclude the other libs (libcommoncpp2 was just left out and we are using rapckaged upstream), I see no real chance of getting MMS in until we have this done ... :?
Lg

Roman

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Thu Jul 26, 2007 4:25 pm

Will see ... maybe it is sufficient to exclude ffmpeg and translate termcap to ncurses ?!

Will keep you informed ...
Lg

Roman

lorenzodes
master
Posts: 772
Joined: Sun Mar 11, 2007 4:50 pm
Location: move.l 4.w,a6

Postby lorenzodes » Fri Jul 27, 2007 11:37 am

Uatschitchun wrote:Will see ... maybe it is sufficient to exclude ffmpeg and translate termcap to ncurses ?!

Will keep you informed ...


Strange... do they have deb packages for xine-lib? That, too, if I am not mistaken, uses an internal ffmpeg library.
"I’m not frightened of dying, anytime will do, I don’t mind. Why should I be frightened of dying? There’s no reason for it, you gotta go sometime"

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Fri Jul 27, 2007 12:12 pm

Debian's xine-libs ship with ffmpeg in upstream, but the libs themselves are built with

Code: Select all

--with-external-ffmpeg

and build-depend on

Code: Select all

libavcodec-dev
libavformat-dev
...


Mplayer is still not part of debian (only debian-multimedia) although they changed over to external ffmpeg, too ... reason here is some patented code ;)
Lg

Roman

lorenzodes
master
Posts: 772
Joined: Sun Mar 11, 2007 4:50 pm
Location: move.l 4.w,a6

Postby lorenzodes » Fri Jul 27, 2007 12:43 pm

Uatschitchun wrote:Debian's xine-libs ship with ffmpeg in upstream, but the libs themselves are built with

Code: Select all

--with-external-ffmpeg

and build-depend on

Code: Select all

libavcodec-dev
libavformat-dev
...


Mplayer is still not part of debian (only debian-multimedia) although they changed over to external ffmpeg, too ... reason here is some patented code ;)


Well, I have always known debianists were strict, but that strict... wow.

p.s.: I have fixed movie_info to correctly parse audio in some mpg files. I must have had my brain switched off when I originally coded that part, lol.

Thanks for your help :)
"I’m not frightened of dying, anytime will do, I don’t mind. Why should I be frightened of dying? There’s no reason for it, you gotta go sometime"

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Fri Jul 27, 2007 2:17 pm

From the split:

Regarding the libraries: ffmpeg is a pain, but could be done. Basicly we need to support several ffmpeg versions but that shouldn't be too hard. Neither termcap, libfs++ (we use s a modified version of libfs++) nor tinyxml seems to be in debian. And then there's imms. We use a quite old version. In 1.1.0 I have changed it so that we can use the latest 3.X version externally as a library but I don't see that change coming into 1.0.8 as it's a quite big one. Hmm, splitting all the external libraries a part will require quite a lot of work. That really saddens me since I know you've worked really hard on the packages and I know they have been a great succes so far...

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Tue Aug 28, 2007 3:45 pm

Here we are ... I finaly found some time :P

1.0.8.5 freshly packaged!

See updated changelog on the 1. page for detailed infos.

Interesting changes for your convenience:

* PT-patches are now part of the debian package
just get the source, enable them in debian/patches/00list and re-build the packages (the corresponding theme is available here: http://mms.kicks-ass.org/forum/viewtopic.php?t=877&highlight=

* For all of you using a DXR3
mms-mpeg (from my server) is now build with dxr3-support, too ;)
If you want to compile your own, do that with:

Code: Select all

DEB_BUILD_OPTIONS="enable-dxr3" dpkg-buildpackage -tc -uc -us -rfakeroot

but be sure to have em8300-headers installed!

Have Phun
Lg

Roman

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Thu Aug 30, 2007 10:05 am

Bump, cause of pre-upstream patch which allows building for sid, too ;)

Added enhanced build instructions for DIY-lovers :P
Lg

Roman

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Wed Oct 24, 2007 9:08 pm

Gutsy-packages online ... see 1. post
Lg

Roman

GFD
Posts: 4
Joined: Sat Oct 27, 2007 5:13 pm
Location: PARIS
Contact:

Postby GFD » Mon Oct 29, 2007 6:20 pm

Where are theme packages for gutsy?

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Wed Oct 31, 2007 7:28 am

Haven't uploaded yet ;)

Will see to fix that! Until then you can use feisty package for themes (or any other) cause they do not depend ...
Lg

Roman


Return to “announcements”

Who is online

Users browsing this forum: No registered users and 1 guest