mms-1.1.0_pre1832.ebuild

Moderator: Moderator

User avatar
vitalogy
Posts: 39
Joined: Tue Sep 04, 2007 5:31 pm
Location: Germany

Postby vitalogy » Thu Feb 07, 2008 4:17 pm

update 07.02.08
mms-1.1.0_rc2 released
added "weather" use-flag + WeatherConfig.patch to locate right place of get_weather.sh
please set Weather.xml in /etc/mms/WeatherConfig to a writeble dir
removed stuff from rc1

have a loook at the first post of this thread

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Postby acmelabs » Thu Feb 07, 2008 6:27 pm

vitalogy wrote:update 07.02.08
mms-1.1.0_rc2 released
added "weather" use-flag + WeatherConfig.patch to locate right place of get_weather.sh
please set Weather.xml in /etc/mms/WeatherConfig to a writeble dir
removed stuff from rc1

have a loook at the first post of this thread

Thanks a lot. I really appreciate your work.

Regards,
Andreas

aadamson
Posts: 10
Joined: Wed Feb 06, 2008 3:31 am

Postby aadamson » Thu Feb 07, 2008 6:36 pm

2 comments.

Why don' you remove the -j1 from the final emake statement in the digest, this will allow those of us that use distcc (distributed compiles) to use that capability. I removed it manually and regenerated the digest, build time was shortened drastically.

Second comment. just like my experiences with building mms rc2 from the source tarball (without the ebuild process)... on Gentoo, even after a fully functioning rc1, this will build and run, but as soon as you go to the play movies from hard drive menu item and select it, you crash out of the applicaiton with the following error.

Code: Select all

mms: module.cpp:340: std::string Module::get_parent_id(const std::string&, SQLDatabase&, ost::Mutex&, const std::list<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&): Assertion `!parent_id.empty()' failed.
Aborted


So far, I've seen no recommended fix and others are getting this same error on other than gentoo linux installs

Alan

ps. I tried it with and without the boost modules and got the same error... is there some new dependancy that isn't accounted for in the process?

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Thu Feb 07, 2008 10:03 pm

rc3 out now to fix that :)

User avatar
vitalogy
Posts: 39
Joined: Tue Sep 04, 2007 5:31 pm
Location: Germany

Postby vitalogy » Fri Feb 08, 2008 5:31 pm

arj wrote:rc3 out now to fix that :)


thx a lot :P
now movie database works again :D

update 08.02.08
mms-1.1.0_rc3 released
"emake -j1 || die" in the ebuild commented out (so this was taken from the old mmsv2-1.0.8.3.ebuild, i don't have tested the mms ebuild without this befor, but it works - thx to aadamson)

rikky
Posts: 1
Joined: Sat Mar 29, 2008 12:53 pm

Postby rikky » Sat Mar 29, 2008 1:02 pm

Thanks for the ebuild. I just used it to install 1.1.0-rc4. It worked, but it installed the file /usr/bin/midentify which is also installed by the mplayer ebuild. Is this file new in rc4 and is it really the same (or just the same name)?

Thanks,
Rikky

User avatar
vitalogy
Posts: 39
Joined: Tue Sep 04, 2007 5:31 pm
Location: Germany

Postby vitalogy » Mon Mar 31, 2008 4:44 pm

update 31.03.08
mms-1.1.0_rc5 released
added use-flags for clock & notify-area (so this will be enabled by default for the next ebuild i think)

see first post

User avatar
arj
Site Admin
Posts: 2316
Joined: Thu Dec 01, 2005 8:51 pm
Location: Denmark
Contact:

Postby arj » Mon Mar 31, 2008 4:46 pm

Thank you very much! :D

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Mon Mar 31, 2008 5:27 pm

Cool!

What about ffmpeg-thumb?
Lg
Roman

User avatar
acmelabs
Overlord
Posts: 2365
Joined: Mon Feb 20, 2006 9:18 pm
Location: Germany
Contact:

Postby acmelabs » Mon Mar 31, 2008 6:40 pm

vitalogy wrote:update 31.03.08
mms-1.1.0_rc5 released
added use-flags for clock & notify-area (so this will be enabled by default for the next ebuild i think)

see first post

Thank you very much for having an eye on this!

Regards,
Andreas

User avatar
vitalogy
Posts: 39
Joined: Tue Sep 04, 2007 5:31 pm
Location: Germany

Postby vitalogy » Wed Apr 02, 2008 12:12 pm

Uatschitchun wrote:Cool!

What about ffmpeg-thumb?


i test this, but i get some black thumbs for my movies
so its faster and pictures are ok
but for videos is better to use mplayer for thumbnailing
perhaps for the next ebuild as additional use-flag

and so there is another question!
mplayer is default option for thumbnailing?
if i don't have mplayer installed and choose not --enable-ffmpeg-thumbs!
what do i get? black thumbs at all?

regards
MichaeL

User avatar
Uatschitchun
Overlord
Posts: 3189
Joined: Tue Dec 06, 2005 6:55 pm
Location: Germany
Contact:

Postby Uatschitchun » Wed Apr 02, 2008 1:16 pm

vitalogy wrote:if i don't have mplayer installed and choose not --enable-ffmpeg-thumbs!
what do i get? black thumbs at all?

Yes :cry:

That what
http://mymediasystem.org/flyspray/?do=details&task_id=467&histring=mplayer
was for ...

If you are able to provide Lorenzo with testfiles for thumbs having problems, ffmpeg-thumb will get better! So let's upload our movies to lorenzo ;)

RealMedia is a problem for ffmpeg only supporting that in latest svn:
http://mymediasystem.org/flyspray/?do=details&task_id=589
Lg

Roman

User avatar
vitalogy
Posts: 39
Joined: Tue Sep 04, 2007 5:31 pm
Location: Germany

Postby vitalogy » Wed Apr 02, 2008 11:37 pm

okay, thx!
so mplayer should be installed or ffmpeg-thumbs should be activated for thumbnailing!
and this choice is better to have in option menu inside mms. this were great!

thx all devs for mms

regards
MichaeL

(so the next will be last.fm support in ebuild - i love this)

swer
Posts: 7
Joined: Tue May 22, 2007 10:55 am

joshuarich-gentoo-overlay

Postby swer » Thu Apr 03, 2008 5:53 pm

Hello

Just trait to add the joshuarich overlay but layman dos not find it. It's not on the global overlay list. So how can i use it. So can someone please help.


And sorry for my pure English hope you did understood me.

User avatar
vitalogy
Posts: 39
Joined: Tue Sep 04, 2007 5:31 pm
Location: Germany

Postby vitalogy » Sat Apr 05, 2008 10:26 am

edit /etc/layman/layman.cfg

add http://www.mso.anu.edu.au/~joshua/gento ... verlay.xml to overlays


Return to “announcements”

Who is online

Users browsing this forum: No registered users and 1 guest